• 1
  • 2
15 posts :: Page 1 of 2
Par:    (Read 1366 times)  

Anonymous


Bonjour,

Avant tout, sachez que je ne m'y retrouve pas avec les signaux disons, complexe.
Donc allez-y calmement avec vos explications ^^

Je vais expliquer rapidement.
J'ai une gare de "test" qui fait 12 voies.
J'ai regroupé 3 "entrés" de 4 voies, pour faire une sorte "d'arbre".

Seulement, à l'arrivé de mes trains, ils se dirige toujours sur une seule voies, même
si le feux est rouge.
Ce que j'aimerais, c'est que si les 4 premières voies de la gare sont prises, les feux sont
tous rouge et le train suivant qui arrive sera automatiquement dirigé sur les voies 5 à 8.
Et si les voies 1 à 4 et 5 à 8 sont prises, encore une fois le train ira automatiquement sur
les vois 9 à 12.

Si toutes les vois sont utilisés, les train attendrons à l'entrer de "l'échangeur".

Voici le screen de ma gare.

Je vais expliquer mon image.
Les trains:
1: C'est en train en pane dans la voie N°12
2: Un train arrivant en voie N°12 aussi -_-'
3: Là les train sont bien à l'arrêt comme prévus.
Les signaux:
A: Pré-signaux d'entrée
B: Signaux combinés
C: Signaux de sortie
D: Simple signaux

Je me suis tourné vers cette explications: http://wiki.openttd.org/Signaux/Fr#Signaux_de_bloc
J'ai fais quasi la même chose que les images montrés, mais ça ne fonctionne pas, ou alors je
me suis trompé, ce qui est réellement possible.

J'aimerais donc qu'on m'explique clairement comment réaliser cette méthode.

Merci

Par: (pas connecté)    
   
Forum Admin
Admin

Fran-ssnouf



Depuis:: 20/10/17
Messages: 2150

Salut Raptor,

la gare que tu nous montre semble fonctionner correctement d'un point de vu des feux.
Si je comprend bien ce que tu pointe du doigt c'est le train 2 arrêté devant la voix 12, c'est bien ça ?

Il n'aurait pas dû venir jusqu'ici en effet.

Lorsque un bloc de 4 voies est prit (4 trains en gare) est-ce que le signal combo relatif s'allume bien en rouge ?

Par:     

Anonymous


Salut,

Oui, c'est ce que je reproche au train 2, de ne pas avoir choisis la voie qui était en vert.
Mais si jamais d'autre voie se libère, les train irons avant tout sur la voie 12, c'est aussi
cela qui m'ennuie.

Et voila ce que je redoutais ^^
Tu me dis "est-ce que le signale de combo relatif" oulaaaa voila, ce sont ces genres de
mots que j'ai du mal à assimiler Big Grin Donc, je ne vois pas de quoi tu parle désolé.

Par:     

Anonymous


Salut,

Je vais faire un test grandeur nature, et je te dis quoi _D_

Edit : j'ai aucun problème, même en ayant exactement la même situation que toi ... peut être qu'il s'agirait d'un bug, ou je me suis peut être trompé dans l'ordre des signaux.

Quand Franssnouf a écrit le "combo relatif", il parlait du pré-signal combiné (le signal avec sa petite barre verticale jaune) qui agit, via le pré-signal d'entrée (signal avec sa bande horizontale jaune), sur les 4 pré-signaux de sortie du bloc C des voies 9-10-11-12. il s'agit donc du signal situé le plus près de la lettre B.

Est ce que ce signal là est bien rouge quand toutes les voies de la gare sont occupées ?

Par:     

Anonymous


Oui, quand les voies sont occupé, ce signale est bien rouge.

Mais le soucis, c'est que les train continue d'aller sur une des voie même
si c'est rouge, et moi j'aimerais qu'ils restent au début, en attendant qu'une
voie se libère. Je sais que la gare que je prépare ne sera jamais saturé,
celle que je montre n'est qu'un test, mon projet est trois fois plus grand.

As-tu essayé avec le même système que moi.
10 train avec "Chargé complètement"
Et beaucoup de train sans ordre pour "tourner".

J'ai essayé aussi en "bloquant" 3 voies aléatoires de chaque branche, pour
être plus clair, j'ai mis des train en "charger complètement" en voie 1, 2, 4,
6, 7, 8, 10, 11, et 12. Ce qui laisse les voies 3, 5, 9 de libre, mais là aussi
certain train entre dans une voie déjà utilisé.

Pour que vous voyez, et testez comme moi, je vous met ma sauvegarde.
Sauvegarde test 01

Le test se situe prêt de la ville "Liège" légèrement sur la droite en bas, sur une île.

Dernier petit "soucis".
Les trains n'ayant pas d'ordre, ou des ordres simples, se dirigent dans 75%
des cas à l'extérieur de "l'entrer", vers les voies 9 à 12
Et les trains ayant un ordre de "charger complet" eux vont très souvent en première voies.
C'est normal ?

En tout cas merci Wink

Par:     

Anonymous


[quote author=Raptor link=topic=1413.msg15332#msg15332 date=1319646405]
Oui, quand les voies sont occupé, ce signale est bien rouge.
[/quote]

Donc y'a pas d'erreur de signalisation ...

[quote author=Raptor link=topic=1413.msg15332#msg15332 date=1319646405]
Mais le soucis, c'est que les train continue d'aller sur une des voie même
si c'est rouge, et moi j'aimerais qu'ils restent au début, en attendant qu'une
voie se libère. Je sais que la gare que je prépare ne sera jamais saturé,
celle que je montre n'est qu'un test, mon projet est trois fois plus grand.[/quote]

J'ai fait tourner un petit peu le bazard en avance rapide, la situation problématique n'est apparu qu'une seule fois, quand tu as mis en mode pause.

[quote author=Raptor link=topic=1413.msg15332#msg15332 date=1319646405]
As-tu essayé avec le même système que moi.
10 train avec "Chargé complètement"
Et beaucoup de train sans ordre pour "tourner".
[/quote]

Oui je viens d'essayer à l'instant et je rencontre aucune difficultés ...

[quote author=Raptor link=topic=1413.msg15332#msg15332 date=1319646405]
Dernier petit "soucis".
Les trains n'ayant pas d'ordre, ou des ordres simples, se dirigent dans 75%
des cas à l'extérieur de "l'entrer", vers les voies 9 à 12
Et les trains ayant un ordre de "charger complet" eux vont très souvent en première voies.
C'est normal ?[/quote]

euh ... Benoît ? fou1 fou1

[quote author=Raptor link=topic=1413.msg15332#msg15332 date=1319646405]
En tout cas merci Wink
[/quote]

De rien c'est normal _D_

Par:     

Anonymous


Salut,

Merci de tes réponses.
C'est bizarre que tu n'ai rien, car moi je l'ai le soucis :/

Et euuu: "Benoit" ? Tu peux traduire car moi pas comprendre toi  aieeee

Par: (pas connecté)    
   
Forum Admin
Admin

Fran-ssnouf



Depuis:: 20/10/17
Messages: 2150

eek C'est incompréhensible, ce qui est sûr c'est qu'il n'y a pas d'erreur de signaux.
Peut-être une option avancée concernant les trains ? ou les présignaux... mais je ne vois toujours pas.

as-tu des grfs dans cette partie, si oui quels grfs utilises-tu ?

[FR]Benoit est l'expert de la configue, le maître du goulp et plein d'autre trucs  siflote

Par:     

Anonymous


Salut,

Je ré-édit mon sujet, j'avais écrit beaucoup de choses mais ça y est, j'ai
trouvé d'où venait mon erreur, enfin, fallait y penser Big Grin
C'est tout bête, et bon à savoir, c'est très simple, les train sans ordres
utilisaient cette voie-là exclusivement.

J'ai fais deux gares identique, regardez:
Screen

Et ça fonctionne parfaitement, avec, je dois l'avouer, un assez gros rendement.
Actuellement, pas loin de 30 train très petit, donc rapide, entrant/sortant
sans arrêt  ;D

Merci quand même pour vos idées et autres, ça ma permis de trouver la
solution.

Raptor Wink

Par:     

Anonymous


[quote author=Raptor link=topic=1413.msg15334#msg15334 date=1319655677]
Et euuu: "Benoit" ? Tu peux traduire car moi pas comprendre toi  aieeee
[/quote]

Bhé, j'appelais juste [FR]Benoit, Ze boss des codes des OpenTTD, patchs etc etc ... _D_

Je viens de revérifier mes ordres, parce que si j'avais fait exactement la même chose que toi, j'aurais eu le même problème. Mais en fait ... j'avais fait à ma manière sans vraiment recopier : j'avais mis un point de contrôle ; les trains avait pour ainsi dire un vrai itinéraire de passage  :-|>

Encore une problème de résolu  ggg ggg

15 posts :: Page 1 of 2
  • 1
  • 2